Marten - Hello World Example

This document will give you a quick introduction to the Marten integrated software development environment (IDE) by showing you how to
create an application that displays the classic "Hello world!".

To begin, launch the IDE by locating the Marten application icon inside the Marten IDE folder
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The Marten IDE will start up and display a menu bar at the top of the screen. In addition a Projects window displaying a list of open projects
will appear. The window will be empty since you have no open projects yet. Create a new project by clicking in the unoccupied or white
space of the Projects window with the Command key held down (Cmd-Click) OR hold down the Control key, click in the white space, and

then select "New Project" from the contextual menu.
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In order to create a new project, a new project application must be created for that project. A Save As dialog window will open allowing you
to save the new application.
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You should strive to keep your project files organized and not simply put them in the default Documents folder. Create a new folder for your
project, select it, and then rename your project application "Hello World.app" and save it.



Save: MacVPL

Save As: Hello World.app B

Where: ' | Hello World Project %)

( cancel ) @

The Projects Window will now display a new project item ( a "row") representing the newly created "Hello World" project. The project item
will have the default name of "Hello World" and the text of the name will be selected.
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Hit the Return Key to accept the default name. The edit text frame will disappear and the project item will be selected with the "unsaved
changes" color. This color will vary depending on your highlight color settings which can be modified by the Appearance control in System
Preferences.
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At this point, your project does not know about basic operations like multiplication ( "*" ) or detaching the leftmost element of a list (
"detach-1" ). These "primitive" operations must be explicitly loaded into a newly created project. Select the Hello World project row and
then select the "Add To Project..." menu item under the File menu.
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A Choose Object Navigation will open up. Navigate to the Frameworks folder where the Marten libraries were installed
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and select the MacOSCarbon, Standard, and UIAqua frameworks. Then click the Choose button.
At this point, you should save your work. To save the project, select the row and then select the "Save" menu item under the "File" menu OR

type "S" with the Command Key held down. A Save dialog will open. Accept the suggested name and click the Save button. It is
recommended that you keep the project file names consistent with the project names.
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After saving, the project item will have just the "selected" coloration.
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The organization of a Marten project is roughly this: Operations are the basic elements of execution and are stored in sets called "Cases".
Cases are stored in Methods, Methods are stored in Classes OR Sections, and Classes are stored in Sections which in turn are stored in
Projects.

Here is the hierarchy of a project:

Project



Libraries (Bundles)
Primitives
Sections
Classes
Instance Attributes
Class Methods
Cases
Operations
Class Attributes
Universal Methods
Cases
Operations
Persistents

In order to "write" some code you will start from the top down and create a new section, then a new universal method along with a case, and
then finally you will create the operations required to display "Hello world!".

Project
Sections
Universal Methods
Cases
Operations

The creation of a new section proceeds in the standard manner. You open up a list of sections and then create a new one by a Command-
Click or Control-Click contextual menu select. To open up the list of sections for a project, double-click on the Section icon in the Hello
World project row or select the "Sections..." command under the Window menu. The Section icon is the middle diamond-shaped one.
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The list of sections for the project is displayed and is of course empty.
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Hold down the Command key and click in the white space of the window OR hold down the Control key, click in the white space, and then
select "New Section" from the contextual menu. A new section item is created with the name of the section selected.
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Type "Hello Section" as the new name for the section and hit the Return key.
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You should again save your work. To save the section, select the row and then select the "Save" menu item under the "File" menu OR type
"S" with the Command key held down.
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Type "Hello Section" as the new name for the section and hit the Return key.

While methods are most often stored in a class as "Class Methods", a section can also have methods. These methods are known as "Universal
Methods" or "Universals" for short. To create a new universal, you must open up the list of universals for the section by double-clicking the
Universal icon in the Hello Section row OR selecting the "Universal Methods..." command from under the Window menu and choosing the
appropriate section. The method icon is the middle square-shaped one.
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The list of universal methods for the sections appears.
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Create a new universal method by clicking in the white space with the Command key held down OR hold down the Control key, click in the
white space, and then select "New Universal" from the contextual menu. A new universal item is created with the name of the universal

selected.
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Rename the newly created method to "Display Hello".
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It is now time to create the code that will display "Hello world!". Operations are stored in cases which in turn are stored in methods. Open
up a list of cases AND a canvas in which to place operations by double-clicking the Case icon in the Hello Method row.
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The cases of the method are displayed in list on the left. There is currently only one case for this method. Cases do not get names, but



instead are numbered sequentially. You did not have to create a case because every newly created method will also have one case created for
it as well. The horizontal bars represent the top and bottom operations which are the "Input Bar" and "Output Bar" operations respectively.
The input bar contains the inputs to your method and the output bar contains the outputs from your method. The input bar will be the first
operation executed in your case while the output bar will be the last.

You can move operations around by mousing down on the operation and then keeping the mouse down while dragging.

Create a new operation in the case by clicking in the white space while holding the Command key down OR hold down the Control key,
click in the white space, and then select "New Operation" from the contextual menu. A generic or "simple" operation will be created at the
location where you clicked and a blinking "I beam" cursor will appear in the operation text box.
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The first operation you will create is a Constant operation, an operation that when executed, creates a new piece of data from some text. The
constant operation requires this textual definition of the constant data it is to provide. In your case, it is the text "Hello world!". Type this
text into the simple operation text box and press the Return key.

The operation will be transformed into a constant operation with text "Hello World!".
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The basic operations of Marten are called "primitives" and are loaded into the environment when you open a project or when you explicitly
add them using the "Add To Project" menu item as you did earlier. The Carbon primitives contain operations that utilize special MacOS X
system calls. In particular, the Carbon primitives contain the "show" primitive whose function is to provide a simple display of text.

To add the show primitive operation, command-click in the white space of the case. A method operation will be created. Type the word
"show" into the operation text box. The operation will change background to the "primitive" theme and create one input.
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The input to the show primitive is depicted by a small circle. This input is called a "Terminal". Outputs from an operation are called "Roots"
and coding in Marten is simply a matter of creating operations and then connecting the roots of operations to terminals of other operations.

Connect the root of the constant operation to the show primitive by first selecting (click-on) the root of the constant operation. It will change
color. Next hold down the Option key. A line stretching from the root to the current position of the mouse will appear. Move the mouse over
the terminal of the show primitive. The line will "snap" to the terminal and the terminal will change color. When this happens, click the
mouse and a datalink will be created between the root and terminal.
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You have now created a fully functional Marten method. Test out your new method by selecting the "Run Method" menu item from under the
"Run" menu.
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The application will run and display a window containing the text "Hello world!". You have created your first functioning Marten project!
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Methods can come in various types. One special type for a project is the "Main" method. This is the initial method that will be run when
your application starts up. The "Display Hello" universal will be your main method and to set the type appropriately, hold the Option key
down and mouse down on the universal. A contextual menu will appear listing a variety of actions that can be taken. You should select the
Main menu item from the submenu of the Install menu.
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Release the mouse button. The universal "Hello Method" is now the main method of the project and of your application. If you reopen the
"Display Hello" method, you will find that a root has been added to the input bar and a terminal added to the output bar. This is because the
main method of an application must take one input and provide one output to function properly. The nature of these inputs and outputs does
not matter at this point.
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One of the special features of the Marten IDE is the ability to create an application very easily. You already started this process by saving an
application in an earlier step. This application cannot be run at this stage because it's internal files have not been updated with all your
changes to the project. To synchronize your application with your project, select the Update menu item from under the File menu.
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After the updating has finished, quit the Marten application by selecting the Quit Marten command under the Marten system menu.
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To run your newly created application, navigate to the Hello World project folder. There should be three files in the project folder, your
application "Hello World", the project file "Hello World.vpx", and the section file "Hello Section.vpl".
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Double click the icon of the Hello World application. Your application will launch and display once again:
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Congratulations! You have created your first Marten application. Please refer to the support page on the Andescotia website at
www.andescotia.com for further information on using the Marten IDE to create more sophisticated programs.



